summaryrefslogtreecommitdiff
path: root/modules/chromium.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/chromium.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/chromium.nix')
-rw-r--r--modules/chromium.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/chromium.nix b/modules/chromium.nix
new file mode 100644
index 0000000..c7842d5
--- /dev/null
+++ b/modules/chromium.nix
@@ -0,0 +1,29 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.chromium;
+in
+{
+ options.nixfiles.modules.chromium.enable = mkEnableOption "Chromium";
+
+ config = mkIf cfg.enable {
+ hm = {
+ home.packages = with pkgs; [ profile-cleaner ];
+
+ programs.chromium = {
+ enable = true;
+
+ package = pkgs.ungoogled-chromium;
+
+ extensions = [
+ { id = "cjpalhdlnbpafiamejdnhcphjbkeiagm"; } # uBlock Origin
+ ];
+ };
+ };
+ };
+}