summaryrefslogtreecommitdiff
path: root/modules/common/alacritty.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
commit482bcef47a3b7ee63553c58d200065857ec42b1c (patch)
treeface7032b62c8957df4a84b2fc0c4adc47020f9e /modules/common/alacritty.nix
parent029acb0781f5a0e75dfd7a64cf8512c8cf12f07b (diff)
2024-03-02
Diffstat (limited to 'modules/common/alacritty.nix')
-rw-r--r--modules/common/alacritty.nix96
1 files changed, 4 insertions, 92 deletions
diff --git a/modules/common/alacritty.nix b/modules/common/alacritty.nix
index be3af21..892516b 100644
--- a/modules/common/alacritty.nix
+++ b/modules/common/alacritty.nix
@@ -12,104 +12,16 @@ in {
config = mkIf cfg.enable {
hm.programs.alacritty = {
enable = true;
- settings = with config.nixfiles.modules; {
+ settings = {
window = {
- padding = with config.fontScheme.monospaceFont; {
- x = size;
- y = size;
+ padding = with config.stylix.fonts.sizes; {
+ x = terminal;
+ y = terminal;
};
dynamic_padding = false;
decorations = "Full";
startup_mode = "Maximized";
};
- font = with config.fontScheme.monospaceFont; {
- normal = {
- inherit family;
- style = "Regular";
- };
- bold = {
- inherit family;
- style = "Bold";
- };
- italic = {
- inherit family;
- style = "Italic";
- };
- bold_italic = {
- inherit family;
- style = "Bold Italic";
- };
- inherit size;
- };
- colors = with config.colourScheme; {
- primary = {
- inherit background foreground;
- dim_foreground = "None";
- bright_foreground = "None";
- };
- cursor = {
- text = "CellBackground";
- cursor = "CellForeground";
- };
- vi_mode_cursor = {
- text = "CellBackground";
- cursor = "CellForeground";
- };
- search = {
- matches = {
- foreground = white;
- background = red;
- };
- focused_match = {
- foreground = red;
- background = black;
- };
- };
- hints = {
- start = {
- foreground = black;
- background = yellow;
- };
- end = {
- foreground = yellow;
- background = black;
- };
- };
- line_indicator = {
- foreground = "None";
- background = "None";
- };
- footer_bar = {
- foreground = black;
- background = white;
- };
- selection = {
- text = "CellBackground";
- background = "CellForeground";
- };
- normal = {
- inherit
- black
- red
- green
- yellow
- blue
- magenta
- cyan
- white
- ;
- };
- bright = {
- black = brightBlack;
- red = brightRed;
- green = brightGreen;
- yellow = brightYellow;
- blue = brightBlue;
- magenta = brightMagenta;
- cyan = brightCyan;
- white = brightWhite;
- };
- };
selection.save_to_clipboard = true;
cursor = {
style = {