summaryrefslogtreecommitdiff
path: root/modules/common/common/shell/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-09-16 14:47:29 +0300
committerAzat Bahawi <azat@bahawi.net>2023-09-16 14:47:29 +0300
commit190bf349658ceb6f64c6d69cdccbddfb5491f894 (patch)
tree33a563624d4725cc042f7dc2f805078e8f34818e /modules/common/common/shell/default.nix
parentd58f6d509cd81c6c21739f3bf0fcec7fa623ee9f (diff)
2023-09-16
Diffstat (limited to 'modules/common/common/shell/default.nix')
-rw-r--r--modules/common/common/shell/default.nix30
1 files changed, 12 insertions, 18 deletions
diff --git a/modules/common/common/shell/default.nix b/modules/common/common/shell/default.nix
index 2b034e6..be86bd8 100644
--- a/modules/common/common/shell/default.nix
+++ b/modules/common/common/shell/default.nix
@@ -104,16 +104,6 @@ with lib; {
name = "upper";
command = ["tr" "'[:lower:]'" "'[:upper:]'"];
})
- (mkAlias {
- name = "disk";
- command = [
- "df"
- "--human-readable"
- "--exclude-type=tmpfs"
- "--exclude-type=devtmpfs"
- "2>/dev/null"
- ];
- })
]
))
// genAttrs ["grep" "egrep" "fgrep"]
@@ -130,12 +120,16 @@ with lib; {
home.packages = with pkgs; [grc];
};
- environment.systemPackages = with pkgs; [
- bash-completion
- bc
- gawk
- hr
- moreutils
- pv
- ];
+ environment = {
+ etc."grc.conf".source = "${pkgs.grc}/etc/grc.conf";
+
+ systemPackages = with pkgs; [
+ bash-completion
+ bc
+ gawk
+ hr
+ moreutils
+ pv
+ ];
+ };
}