summaryrefslogtreecommitdiff
path: root/modules/common/curl.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-19 17:50:35 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-19 17:50:35 +0300
commit91fb4f28ef5d87e8bcf7749928d30ba4a9cbbd34 (patch)
treee07291fcb1cf62a561ffe58d1fd8e2968ff6fcb3 /modules/common/curl.nix
parentf1e8dc736a904703eaa97ccf3d5cde3f69101c38 (diff)
2023-02-19
Diffstat (limited to 'modules/common/curl.nix')
-rw-r--r--modules/common/curl.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/common/curl.nix b/modules/common/curl.nix
new file mode 100644
index 0000000..e7bee31
--- /dev/null
+++ b/modules/common/curl.nix
@@ -0,0 +1,38 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.curl;
+in {
+ options.nixfiles.modules.curl.enable =
+ mkEnableOption "Wether to enable cURL.";
+
+ config = mkIf cfg.enable {
+ hm.home.file.".curlrc".text = ''
+ connect-timeout = 60
+ progress-bar
+ referer = ";auto"
+ remote-time
+ show-error
+ '';
+
+ environment.systemPackages = with pkgs; [
+ curl
+ (writeShellScriptBin "0x0" ''
+ url="https://0x0.st"
+ form="file=@"
+
+ if [ -t 0 ] && [ -n "$1" ]; then
+ form="$form$1"
+ else
+ form="$form-"
+ fi
+
+ ${curl}/bin/curl --form "$form" "$url"
+ '')
+ ];
+ };
+}