summaryrefslogtreecommitdiff
path: root/modules/common/curl.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/curl.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/curl.nix')
-rw-r--r--modules/common/curl.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/modules/common/curl.nix b/modules/common/curl.nix
deleted file mode 100644
index 6895262..0000000
--- a/modules/common/curl.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.curl;
-in
-{
- options.nixfiles.modules.curl.enable = mkEnableOption "cURL";
-
- config = mkIf cfg.enable {
- hm.xdg.configFile.".curlrc".text = ''
- connect-timeout = 60
- progress-bar
- remote-time
- show-error
- '';
-
- environment.systemPackages = with pkgs; [
- curl
- (writeShellScriptBin "0x0" ''
- url="https://0x0.st"
- form="file=@"
-
- if [ -t 0 ] && [ -n "$1" ]; then
- form="$form$1"
- else
- form="$form-"
- fi
-
- ${getExe curl} --form "$form" "$url"
- '')
- ];
- };
-}