summaryrefslogtreecommitdiff
path: root/modules/common/editorconfig.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-02-20 00:53:48 +0300
committerAzat Bahawi <azat@bahawi.net>2024-02-20 00:53:48 +0300
commitd907b7b8f0aecee0f9eba12b09b929d720d07a8d (patch)
tree4f6bbbe605ebf96e1aefbc657dc975208b2436d1 /modules/common/editorconfig.nix
parentf1dc3ecad357ceb8be34eca91fafca4d2a4f924e (diff)
2024-02-20
Diffstat (limited to 'modules/common/editorconfig.nix')
-rw-r--r--modules/common/editorconfig.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/modules/common/editorconfig.nix b/modules/common/editorconfig.nix
index 822acf6..537912f 100644
--- a/modules/common/editorconfig.nix
+++ b/modules/common/editorconfig.nix
@@ -29,7 +29,7 @@ in {
};
# https://go.dev/doc/effective_go#formatting
- "*.go" = {
+ "{*.go,go.mod}" = {
indent_size = 2;
indent_style = "tab";
};
@@ -66,7 +66,7 @@ in {
indent_style = "space";
};
- "*.{asm,s}" = {
+ "*.{asm,s,S}" = {
indent_size = 4;
indent_style = "spaces";
};
@@ -90,6 +90,12 @@ in {
indent_style = "space";
};
+ # https://nickel-lang.org/user-manual/syntax
+ "*.ncl" = {
+ indent_size = 2;
+ indent_style = "space";
+ };
+
# https://developer.hashicorp.com/terraform/language/syntax/style
"*.{tf,hcl}" = {
indent_size = 2;