summaryrefslogtreecommitdiff
path: root/modules/common/eza.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/eza.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/eza.nix')
-rw-r--r--modules/common/eza.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/modules/common/eza.nix b/modules/common/eza.nix
deleted file mode 100644
index 96b7d4c..0000000
--- a/modules/common/eza.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.eza;
-in
-{
- options.nixfiles.modules.eza.enable = mkEnableOption "eza, an alternative to ls";
-
- config = mkIf cfg.enable {
- nixfiles.modules.common.shell.aliases = rec {
- ls = "eza --smart-group --dereference";
- ll = "${ls} --long --grid";
- la = "${ll} --header --all";
- };
-
- hm.home.packages = [ pkgs.eza ];
- };
-}