summaryrefslogtreecommitdiff
path: root/modules/common/fonts.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-07-30 20:06:40 +0300
committerAzat Bahawi <azat@bahawi.net>2023-07-30 20:06:40 +0300
commit031c27317d63a98bb9896a4baa9b19c155ac62a9 (patch)
tree3051b34857540420f4142e0b8360038cc609ea13 /modules/common/fonts.nix
parent5834fee454d8fbe4d3eace6fa4d1f005cef0cbbb (diff)
2023-07-30
Diffstat (limited to 'modules/common/fonts.nix')
-rw-r--r--modules/common/fonts.nix25
1 files changed, 12 insertions, 13 deletions
diff --git a/modules/common/fonts.nix b/modules/common/fonts.nix
index f3a79c2..adf6a3f 100644
--- a/modules/common/fonts.nix
+++ b/modules/common/fonts.nix
@@ -1,12 +1,9 @@
{
- config,
lib,
pkgs,
...
}:
-with lib; let
- cfg = config.nixfiles.modules.fonts;
-in {
+with lib; {
imports = [
(mkAliasOptionModule ["fontScheme"] [
"nixfiles"
@@ -19,6 +16,17 @@ in {
options.nixfiles.modules.fonts = {
enable = mkEnableOption "fonts and their configurations";
+ packages = mkOption {
+ description = "Font packages to install.";
+ type = with types; listOf package;
+ default = with pkgs; [
+ (iosevka-bin.override {variant = "aile";})
+ (iosevka-bin.override {variant = "etoile";})
+ iosevka-bin
+ sarasa-gothic
+ ];
+ };
+
fontScheme = let
mkFont = {
family,
@@ -79,13 +87,4 @@ in {
};
};
};
-
- config = mkIf cfg.enable {
- fonts.packages = with pkgs; [
- (iosevka-bin.override {variant = "aile";})
- (iosevka-bin.override {variant = "etoile";})
- iosevka-bin
- sarasa-gothic
- ];
- };
}