about summary refs log tree commit diff
path: root/modules/common/htop.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/htop.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to 'modules/common/htop.nix')
-rw-r--r--modules/common/htop.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/modules/common/htop.nix b/modules/common/htop.nix
deleted file mode 100644
index 647abf7..0000000
--- a/modules/common/htop.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
-  cfg = config.nixfiles.modules.htop;
-in
-{
-  options.nixfiles.modules.htop.enable = mkEnableOption "htop";
-
-  config = mkIf cfg.enable {
-    hm.programs.htop = {
-      enable = true;
-
-      settings = with config.hm.lib.htop; {
-        fields = with fields; [
-          PID
-          USER
-          PRIORITY
-          NICE
-          M_SIZE
-          M_RESIDENT
-          M_SHARE
-          STATE
-          PERCENT_CPU
-          PERCENT_MEM
-          TIME
-          COMM
-        ];
-        account_guest_in_cpu_meter = 1;
-        detailed_cpu_time = 0;
-        enable_mouse = 0;
-        find_comm_in_cmdline = 1;
-        header_margin = 1;
-        hide_function_bar = 1;
-        hide_kernel_threads = 1;
-        hide_userland_threads = 1;
-        highlight_base_name = 1;
-        highlight_changes = 0;
-        highlight_changes_delay_secs = 1;
-        highlight_deleted_exe = 1;
-        highlight_megabytes = 1;
-        highlight_threads = 1;
-        shadow_other_users = 1;
-        show_cpu_frequency = 1;
-        show_cpu_usage = 1;
-        show_program_path = 0;
-        show_thread_names = 0;
-        strip_exe_from_cmdline = 1;
-        tree_view = 1;
-        tree_view_always_by_pid = 1;
-        update_process_names = 1;
-      };
-    };
-  };
-}

Consider giving Nix/NixOS a try! <3