summaryrefslogtreecommitdiff
path: root/modules/common/mpv.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/mpv.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/mpv.nix')
-rw-r--r--modules/common/mpv.nix156
1 files changed, 0 insertions, 156 deletions
diff --git a/modules/common/mpv.nix b/modules/common/mpv.nix
deleted file mode 100644
index 9cd1e91..0000000
--- a/modules/common/mpv.nix
+++ /dev/null
@@ -1,156 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.mpv;
-in
-{
- options.nixfiles.modules.mpv.enable = mkEnableOption "mpv";
-
- config = mkIf cfg.enable {
- hm.programs.mpv = {
- enable = true;
-
- package =
- with pkgs;
- wrapMpv
- (mpv-unwrapped.override {
- bs2bSupport = false;
- cacaSupport = false;
- dvbinSupport = false;
- dvdnavSupport = false;
- swiftSupport = false;
- })
- {
- scripts = with mpvScripts; [
- autoload
- sponsorblock
- ];
- };
-
- bindings = {
- "RIGHT" = "seek 10";
- "LEFT" = "seek -10";
- "UP" = "seek 60";
- "DOWN" = "seek -60";
-
- "Shift+RIGHT" = "no-osd seek 1 exact";
- "Shift+LEFT" = "no-osd seek -1 exact";
- "Shift+UP" = "no-osd seek 5 exact";
- "Shift+DOWN" = "no-osd seek -5 exact";
-
- "Alt+h" = "add sub-delay +1";
- "Alt+l" = "add sub-delay -1";
-
- "Alt+k" = "add sub-scale +0.1";
- "Alt+j" = "add sub-scale -0.1";
-
- "B" = ''cycle-values background "#000000" "#ffffff"'';
- };
-
- profiles = {
- "protocol.http".force-window = "immediate";
- "protocol.https".profile = "protocol.http";
-
- "extension.gif" = {
- cache = false;
- loop-file = true;
- };
- "extension.png" = {
- profile = "extension.gif";
- video-aspect-override = 0;
- };
- "extension.jpeg".profile = "extension.png";
- "extension.jpg".profile = "extension.png";
- };
-
- config =
- let
- lang = concatStringsSep "," [
- "Japanese"
- "japanese"
- "jp"
- "jpn"
- "jaJP"
- "ja-JP"
- "English"
- "english"
- "en"
- "eng"
- "enUS"
- "en-US"
- "Russian"
- "russian"
- "ru"
- "rus"
- "ruRU"
- "ru-RU"
- ];
- in
- {
- autofit-larger = "100%x95%";
- cache = true;
- cursor-autohide = 1000;
- cursor-autohide-fs-only = true;
- demuxer-max-back-bytes = "20M";
- demuxer-max-bytes = "20M";
- force-seekable = true;
- fullscreen = true;
- msg-color = true;
- msg-module = true;
- prefetch-playlist = true;
- save-position-on-quit = true;
- screenshot-format = "png";
- screenshot-template = "%F [%p]";
- stop-screensaver = true;
- term-osd-bar = true;
- use-filedir-conf = true;
-
- osd-bar-align-y = 0;
- osd-bar-h = 2;
- osd-bar-w = 60;
- osd-border-color = "#FF262626";
- osd-border-size = 2;
- osd-color = "#FFFFFFFF";
- osd-duration = 1000;
- osd-font-size = 40;
- osd-fractions = true;
- osd-level = 1;
- osd-shadow-color = "#33000000";
-
- # osc = false;
-
- blend-subtitles = true;
- embeddedfonts = false;
- sub-ass-force-margins = true;
- sub-ass-force-style = "kerning=yes";
- sub-auto = "fuzzy";
- sub-border-color = "#FF262626";
- sub-border-size = 2.5;
- sub-color = "#FFFFFFFF";
- sub-file-paths-append = "srt";
- sub-fix-timing = true;
- sub-font-size = 40;
- sub-scale-with-window = true;
- sub-shadow-color = "#33000000";
- sub-shadow-offset = 1;
- sub-spacing = 0.5;
- sub-use-margins = true;
-
- audio-file-auto = "fuzzy";
- volume = 100;
- volume-max = 200;
-
- alang = lang;
- slang = lang;
-
- ytdl = true;
- ytdl-raw-options = ''sub-lang="${lang}",write-sub='';
- };
- };
- };
-}