summaryrefslogtreecommitdiff
path: root/modules/common/neovim/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-07-30 19:44:06 +0300
committerAzat Bahawi <azat@bahawi.net>2023-07-30 19:44:06 +0300
commit5834fee454d8fbe4d3eace6fa4d1f005cef0cbbb (patch)
treedb1f73878ab12627df270bc4bc998740da7f9728 /modules/common/neovim/default.nix
parent284d14147ab00f550be1777d5ec0f9ee36a04bd5 (diff)
2023-07-30
Diffstat (limited to 'modules/common/neovim/default.nix')
-rw-r--r--modules/common/neovim/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/common/neovim/default.nix b/modules/common/neovim/default.nix
new file mode 100644
index 0000000..1e5f103
--- /dev/null
+++ b/modules/common/neovim/default.nix
@@ -0,0 +1,27 @@
+{
+ config,
+ inputs,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.neovim;
+in {
+ options.nixfiles.modules.neovim.enable = mkEnableOption "NeoVim";
+
+ config = mkIf cfg.enable {
+ hm = {
+ imports = [inputs.nixvim.homeManagerModules.nixvim];
+
+ programs.nixvim = {
+ enable = true;
+
+ plugins = {
+ lsp.enable = true;
+ nix.enable = true;
+ surround.enable = true;
+ };
+ };
+ };
+ };
+}