about summary refs log tree commit diff
path: root/modules/common/nix.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2024-10-10 03:33:47 +0300
committerazahi <azat@bahawi.net>2024-10-10 03:33:47 +0300
commitc6c9929a090aa8022045514e09ecafd57a954c27 (patch)
tree0a71feedcada203c045f94d01bc2d8b733b067ee /modules/common/nix.nix
parent2024-08-20 (diff)
2024-10-10
Diffstat (limited to 'modules/common/nix.nix')
-rw-r--r--modules/common/nix.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/modules/common/nix.nix b/modules/common/nix.nix
index d1f835c..0ab2888 100644
--- a/modules/common/nix.nix
+++ b/modules/common/nix.nix
@@ -49,7 +49,7 @@ in
           } // configurations // local._module.args
         '';
 
-      programs.bash.shellAliases.nix = "nix --verbose --print-build-logs";
+      programs.bash.shellAliases.nix = "nix --verbose --print-build-logs --no-eval-cache";
     };
 
     nix =
@@ -57,6 +57,8 @@ in
         notSelfInputs = filterAttrs (n: _: n != "self") inputs;
       in
       {
+        package = mkForce pkgs.nix; # Only use stable Nix.
+
         nixPath = mapAttrsToList (n: v: "${n}=${v}") notSelfInputs ++ [
           "nixfiles=${config.my.home}/src/nixfiles"
         ];
@@ -75,15 +77,12 @@ in
             my.username
           ];
 
-          experimental-features = mkForce [
-            "auto-allocate-uids"
-            "cgroups"
-            "fetch-closure"
-            "flakes"
-            "nix-command"
-            "recursive-nix"
-            # "configurable-impure-env"
-            # "pipe-operators"
+          substituters = [
+            "https://cache.tvl.su"
+            "https://nix-community.cachix.org"
+          ];
+          trusted-public-keys = [
+            "cache.tvl.su:kjc6KOMupXc1vHVufJUoDUYeLzbwSr9abcAKdn/U1Jk="
           ];
         };
       };

Consider giving Nix/NixOS a try! <3