summaryrefslogtreecommitdiff
path: root/modules/common/password-store.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/common/password-store.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/common/password-store.nix')
-rw-r--r--modules/common/password-store.nix18
1 files changed, 10 insertions, 8 deletions
diff --git a/modules/common/password-store.nix b/modules/common/password-store.nix
index c9a71ce..e5cd756 100644
--- a/modules/common/password-store.nix
+++ b/modules/common/password-store.nix
@@ -4,26 +4,28 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.password-store;
-in {
- options.nixfiles.modules.password-store.enable =
- mkEnableOption "the standard UNIX password manager";
+in
+{
+ options.nixfiles.modules.password-store.enable = mkEnableOption "the standard UNIX password manager";
config = mkIf cfg.enable {
hm.programs = {
password-store = {
enable = true;
- package = pkgs.pass.withExtensions (p: with p; [pass-otp]);
+ package = pkgs.pass.withExtensions (p: with p; [ pass-otp ]);
settings.PASSWORD_STORE_DIR = "${config.my.home}/.password-store";
};
# HACK https://github.com/NixOS/nixpkgs/issues/183604
- bash.initExtra = let
- completions = "${config.hm.programs.password-store.package}/share/bash-completion/completions";
- in
+ bash.initExtra =
+ let
+ completions = "${config.hm.programs.password-store.package}/share/bash-completion/completions";
+ in
mkAfter ''
source ${completions}/pass-otp
source ${completions}/pass