about summary refs log tree commit diff
path: root/modules/common/profiles/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/profiles/default.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to 'modules/common/profiles/default.nix')
-rw-r--r--modules/common/profiles/default.nix52
1 files changed, 0 insertions, 52 deletions
diff --git a/modules/common/profiles/default.nix b/modules/common/profiles/default.nix
deleted file mode 100644
index 79ce39d..0000000
--- a/modules/common/profiles/default.nix
+++ /dev/null
@@ -1,52 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  this,
-  ...
-}:
-with lib;
-let
-  cfg = config.nixfiles.modules.profiles.default;
-in
-{
-  imports = [
-    ./dev
-    ./email.nix
-    ./headful.nix
-    ./headless.nix
-  ];
-
-  options.nixfiles.modules.profiles.default.enable =
-    mkEnableOption "The most default profile of them all."
-    // {
-      default = true;
-    };
-
-  config = mkIf cfg.enable {
-    assertions = [
-      {
-        assertion = !(with this; isHeadless && isHeadful);
-        message = ''
-          The configuration cannot be both "headful" and "headless" at the same
-          time.
-        '';
-      }
-    ];
-
-    nixfiles.modules = {
-      bat.enable = true;
-      eza.enable = true;
-      htop.enable = true;
-      tmux.enable = true;
-      vim.enable = true;
-    };
-
-    time.timeZone = "Europe/Moscow";
-
-    environment.systemPackages = with pkgs; [
-      file
-      tree
-    ];
-  };
-}

Consider giving Nix/NixOS a try! <3