summaryrefslogtreecommitdiff
path: root/modules/common/profiles/dev/containers.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-09-16 14:47:29 +0300
committerAzat Bahawi <azat@bahawi.net>2023-09-16 14:47:29 +0300
commit190bf349658ceb6f64c6d69cdccbddfb5491f894 (patch)
tree33a563624d4725cc042f7dc2f805078e8f34818e /modules/common/profiles/dev/containers.nix
parentd58f6d509cd81c6c21739f3bf0fcec7fa623ee9f (diff)
2023-09-16
Diffstat (limited to 'modules/common/profiles/dev/containers.nix')
-rw-r--r--modules/common/profiles/dev/containers.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/modules/common/profiles/dev/containers.nix b/modules/common/profiles/dev/containers.nix
index da6b0e1..06826f9 100644
--- a/modules/common/profiles/dev/containers.nix
+++ b/modules/common/profiles/dev/containers.nix
@@ -33,7 +33,6 @@ in {
clusterctl
cmctl
datree
- helm
istioctl
k9s
kubeconform
@@ -42,8 +41,9 @@ in {
kubectl-images
kubectl-tree
kubectx
- kubelogin
+ kubelogin-oidc
kubent
+ kubernetes-helm
kubescape
kubeseal
kubespy
@@ -51,18 +51,18 @@ in {
skaffold
skopeo
stern
- telepresence
+ telepresence2
werf
];
};
programs.bash = {
shellAliases = with pkgs; {
- b = "${buildah}/bin/buildah";
- h = "${helm}/bin/helm";
- k = "${kubectl}/bin/kubectl";
- kns = "${kubectx}/bin/kubens";
- ktx = "${kubectx}/bin/kubectx";
+ b = "buildah";
+ h = "helm";
+ k = "kubectl";
+ kns = "kubens";
+ ktx = "kubectx";
};
initExtra = mkAfter ''
_complete_alias b _buildah buildah