summaryrefslogtreecommitdiff
path: root/modules/common/profiles/dev/containers.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-23 04:20:34 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-23 04:20:34 +0300
commit67b82386d8ad8ae3eea5083bd22809f6192d92a8 (patch)
tree41829a0b3e05a9dbb4b0189e34a7b53e401f489e /modules/common/profiles/dev/containers.nix
parentedf7cc355cb1f55a9301283ebec15e01dc4ffe62 (diff)
2023-11-23
Diffstat (limited to 'modules/common/profiles/dev/containers.nix')
-rw-r--r--modules/common/profiles/dev/containers.nix97
1 files changed, 43 insertions, 54 deletions
diff --git a/modules/common/profiles/dev/containers.nix b/modules/common/profiles/dev/containers.nix
index 6e9346a..027c685 100644
--- a/modules/common/profiles/dev/containers.nix
+++ b/modules/common/profiles/dev/containers.nix
@@ -14,63 +14,52 @@ in {
};
config = mkIf cfg.enable {
- hm = {
- home = {
- sessionVariables = {
- MINIKUBE_IN_STYLE = "false";
- WERF_DEV = "true";
- WERF_INSECURE_REGISTRY = "true";
- WERF_LOG_DEBUG = "true";
- WERF_LOG_PRETTY = "false";
- WERF_LOG_VERBOSE = "true";
- WERF_SYNCHRONIZATION = ":local";
- WERF_TELEMETRY = "false";
- };
+ nixfiles.modules.common.shell.aliases = {
+ b = "buildah";
+ h = "helm";
+ k = "kubectl";
+ kns = "kubens";
+ ktx = "kubectx";
+ };
- packages = with pkgs; [
- argocd
- chart-testing
- clusterctl
- cmctl
- datree
- istioctl
- k9s
- kubeconform
- kubectl
- kubectl-doctor
- kubectl-images
- kubectl-tree
- kubectx
- kubelogin-oidc
- kubent
- kubernetes-helm
- kubeseal
- kubespy
- minikube
- skaffold
- skopeo
- stern
- telepresence2
- werf
- ];
+ hm.home = {
+ sessionVariables = {
+ MINIKUBE_IN_STYLE = "false";
+ WERF_DEV = "true";
+ WERF_INSECURE_REGISTRY = "true";
+ WERF_LOG_DEBUG = "true";
+ WERF_LOG_PRETTY = "false";
+ WERF_LOG_VERBOSE = "true";
+ WERF_SYNCHRONIZATION = ":local";
+ WERF_TELEMETRY = "false";
};
- programs.bash = {
- shellAliases = {
- b = "buildah";
- h = "helm";
- k = "kubectl";
- kns = "kubens";
- ktx = "kubectx";
- };
- initExtra = mkAfter ''
- _complete_alias b _buildah buildah
- _complete_alias h __start_helm helm
- _complete_alias k __start_kubectl kubectl
- _complete_alias kns _kube_namespaces kubens
- _complete_alias ktx _kube_contexts kubectx
- '';
- };
+ packages = with pkgs; [
+ argocd
+ chart-testing
+ clusterctl
+ cmctl
+ datree
+ istioctl
+ k9s
+ kubeconform
+ kubectl
+ kubectl-doctor
+ kubectl-images
+ kubectl-tree
+ kubectx
+ kubelogin-oidc
+ kubent
+ kubernetes-helm
+ kubeseal
+ kubespy
+ minikube
+ skaffold
+ skopeo
+ stern
+ telepresence2
+ werf
+ ];
};
};
}