summaryrefslogtreecommitdiff
path: root/modules/common/profiles/headful.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/profiles/headful.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/profiles/headful.nix')
-rw-r--r--modules/common/profiles/headful.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/modules/common/profiles/headful.nix b/modules/common/profiles/headful.nix
deleted file mode 100644
index cd29225..0000000
--- a/modules/common/profiles/headful.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{
- config,
- lib,
- pkgs,
- this,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.profiles.headful;
-in
-{
- options.nixfiles.modules.profiles.headful.enable = mkEnableOption "headful profile" // {
- default = this.isHeadful;
- };
-
- config = mkIf cfg.enable {
- nixfiles.modules = {
- profiles.dev.enable = true;
-
- alacritty.enable = true;
- aria2.enable = true;
- emacs.enable = true;
- mpv.enable = true;
- openssh.client.enable = true;
- password-store.enable = true;
- vscode.enable = true;
- zathura.enable = true;
- };
-
- hm = {
- home = {
- file.".digrc".text = ''
- +answer
- +multiline
- +recurse
- '';
-
- packages = with pkgs; [
- fd
- ripgrep
- sd
- tldr
- ];
- };
- };
-
- environment.systemPackages = with pkgs; [
- arping
- dnsutils
- inetutils
- ldns
- socat
- tcpdump
- ];
- };
-}