summaryrefslogtreecommitdiff
path: root/modules/common/profiles/headless.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/common/profiles/headless.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/common/profiles/headless.nix')
-rw-r--r--modules/common/profiles/headless.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/modules/common/profiles/headless.nix b/modules/common/profiles/headless.nix
index cc7c326..1f8096c 100644
--- a/modules/common/profiles/headless.nix
+++ b/modules/common/profiles/headless.nix
@@ -5,19 +5,21 @@
this,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.headless;
-in {
- options.nixfiles.modules.profiles.headless.enable =
- mkEnableOption "headless profile" // {default = this.isHeadless;};
+in
+{
+ options.nixfiles.modules.profiles.headless.enable = mkEnableOption "headless profile" // {
+ default = this.isHeadless;
+ };
config = mkIf cfg.enable {
hm.home.file = {
".hushlogin".text = "";
- ".bash_history".source =
- config.hm.lib.file.mkOutOfStoreSymlink "/dev/null";
+ ".bash_history".source = config.hm.lib.file.mkOutOfStoreSymlink "/dev/null";
};
- environment.systemPackages = with pkgs; [alacritty.terminfo];
+ environment.systemPackages = with pkgs; [ alacritty.terminfo ];
};
}