about summary refs log tree commit diff
path: root/modules/common/secrets.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-03-12 20:17:13 +0300
committerazahi <azat@bahawi.net>2025-03-12 20:17:13 +0300
commitc81dc5a13b469c511fac6fa2390b70422d1b4da5 (patch)
tree4dab5909006ab5c25da6bd9fde6a714c7719ded7 /modules/common/secrets.nix
parent2025-02-17 (diff)
2025-03-12 HEAD master
Diffstat (limited to 'modules/common/secrets.nix')
-rw-r--r--modules/common/secrets.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/modules/common/secrets.nix b/modules/common/secrets.nix
index 2b8082e..600b128 100644
--- a/modules/common/secrets.nix
+++ b/modules/common/secrets.nix
@@ -21,11 +21,9 @@
   config = {
     age.identityPaths =
       if this.isHeadful then
-        [ "${config.my.home}/.ssh/id_${lib.my.ssh.type}" ]
+        [ "${config.my.home}/.ssh/${this.hostname}_ed25519" ]
       else
-        config.services.openssh.hostKeys
-        |> lib.filter (attr: attr.type == lib.my.ssh.type)
-        |> map (attr: attr.path);
+        config.services.openssh.hostKeys |> lib.filter (x: x.type == "ed25519") |> map (x: x.path);
 
     environment.systemPackages = with pkgs; [
       age

Consider giving Nix/NixOS a try! <3