about summary refs log tree commit diff
path: root/modules/common/systemd.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2024-10-21 15:39:18 +0300
committerazahi <azat@bahawi.net>2024-10-21 15:39:18 +0300
commit2c03460ad97ed1d10415918e9ec53744e4f920dc (patch)
tree7f7f7438096b2981a39cc3f236e02f6258314624 /modules/common/systemd.nix
parent2024-10-21 (diff)
2024-10-21
Diffstat (limited to 'modules/common/systemd.nix')
-rw-r--r--modules/common/systemd.nix19
1 files changed, 4 insertions, 15 deletions
diff --git a/modules/common/systemd.nix b/modules/common/systemd.nix
index e058ad8..f832518 100644
--- a/modules/common/systemd.nix
+++ b/modules/common/systemd.nix
@@ -1,10 +1,7 @@
 {
   config,
-  pkgs,
-  lib,
   ...
 }:
-with lib;
 {
   ark = {
     files = [ "/etc/machine-id" ];
@@ -22,17 +19,9 @@ with lib;
     };
   };
 
-  services = {
-    resolved = {
-      llmnr = "false";
-      dnsovertls = "opportunistic";
-      fallbackDns = dns.const.quad9.default;
-    };
-
-    journald.extraConfig = ''
-      SystemMaxUse=5G
-    '';
-  };
+  services.journald.extraConfig = ''
+    SystemMaxUse=5G
+  '';
 
   systemd =
     let
@@ -50,7 +39,7 @@ with lib;
 
   environment.variables = {
     SYSTEMD_PAGERSECURE = "1";
-    SYSTEMD_PAGER = "${pkgs.less}/bin/less";
+    SYSTEMD_PAGER = "less";
     SYSTEMD_LESS = "FRSXMK";
   };
 }

Consider giving Nix/NixOS a try! <3