summaryrefslogtreecommitdiff
path: root/modules/common/systemd.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/systemd.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/systemd.nix')
-rw-r--r--modules/common/systemd.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/modules/common/systemd.nix b/modules/common/systemd.nix
new file mode 100644
index 0000000..b393d9f
--- /dev/null
+++ b/modules/common/systemd.nix
@@ -0,0 +1,43 @@
+{ config, pkgs, ... }:
+{
+ ark = {
+ files = [ "/etc/machine-id" ];
+ directories = [ "/var/lib/systemd/coredump" ];
+ };
+
+ my.extraGroups = [ "systemd-journal" ];
+
+ hm.systemd.user.startServices = "sd-switch";
+
+ boot.initrd.systemd = {
+ enable = true;
+ network = {
+ inherit (config.systemd.network) enable;
+ wait-online.enable = false;
+ };
+ };
+
+ services.journald.extraConfig = ''
+ SystemMaxUse=5G
+ '';
+
+ systemd =
+ let
+ extraConfig = ''
+ DefaultTimeoutStartSec=30s
+ DefaultTimeoutStopSec=15s
+ '';
+ in
+ {
+ inherit extraConfig;
+ user = {
+ inherit extraConfig;
+ };
+ };
+
+ environment.sessionVariables = {
+ SYSTEMD_PAGERSECURE = "1";
+ SYSTEMD_PAGER = "${pkgs.less}/bin/less";
+ SYSTEMD_LESS = "FRSXMK";
+ };
+}