about summary refs log tree commit diff
path: root/modules/common/users.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/common/users.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to 'modules/common/users.nix')
-rw-r--r--modules/common/users.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/modules/common/users.nix b/modules/common/users.nix
index e0811b7..ffe6234 100644
--- a/modules/common/users.nix
+++ b/modules/common/users.nix
@@ -1,16 +1,15 @@
 { lib, ... }:
-with lib;
 let
-  home = "/home/${my.username}";
+  home = "/home/${lib.my.username}";
 in
 {
   imports = [
-    (mkAliasOptionModule
+    (lib.mkAliasOptionModule
       [ "my" ]
       [
         "users"
         "users"
-        my.username
+        lib.my.username
       ]
     )
   ];
@@ -26,13 +25,13 @@ in
         password = null;
       };
 
-      ${my.username} = {
+      ${lib.my.username} = {
         isNormalUser = true;
         uid = 1000;
-        description = my.fullname;
+        description = lib.my.fullname;
         inherit home;
-        inherit (my) hashedPassword;
-        openssh.authorizedKeys.keys = [ my.ssh.key ];
+        inherit (lib.my) hashedPassword;
+        openssh.authorizedKeys.keys = [ lib.my.ssh.key ];
         extraGroups = [ "wheel" ];
       };
     };

Consider giving Nix/NixOS a try! <3