summaryrefslogtreecommitdiff
path: root/modules/common/users.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/users.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/users.nix')
-rw-r--r--modules/common/users.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/common/users.nix b/modules/common/users.nix
new file mode 100644
index 0000000..ba1a89b
--- /dev/null
+++ b/modules/common/users.nix
@@ -0,0 +1,34 @@
+{ lib, ... }:
+with lib;
+let
+ home = "/home/${my.username}";
+in
+{
+ imports = [
+ (mkAliasOptionModule [ "my" ] [
+ "users"
+ "users"
+ my.username
+ ])
+ ];
+
+ ark.directories = [ home ];
+
+ users = {
+ mutableUsers = false;
+
+ users = {
+ root.hashedPassword = "@HASHED_PASSWORD@";
+
+ ${my.username} = {
+ isNormalUser = true;
+ uid = 1000;
+ description = my.fullname;
+ inherit home;
+ inherit (my) hashedPassword;
+ openssh.authorizedKeys.keys = [ my.ssh.key ];
+ extraGroups = [ "wheel" ];
+ };
+ };
+ };
+}