summaryrefslogtreecommitdiff
path: root/modules/common/vim/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/common/vim/default.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/common/vim/default.nix')
-rw-r--r--modules/common/vim/default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/modules/common/vim/default.nix b/modules/common/vim/default.nix
deleted file mode 100644
index 93729bc..0000000
--- a/modules/common/vim/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.vim;
-in
-{
- options.nixfiles.modules.vim = {
- enable = mkEnableOption "Vim";
-
- rc = mkOption {
- type = types.str;
- default = readFile ./rc.vim;
- description = "Configuration file.";
- };
-
- plugins = mkOption {
- type = with types; listOf package;
- default = with pkgs.vimPlugins; [
- editorconfig-vim
- vim-eunuch
- vim-nix
- vim-sensible
- vim-sleuth
- vim-surround
- vim-unimpaired
- ];
- description = "Plugins.";
- };
- };
-
- config = mkIf cfg.enable {
- hm.stylix.targets.vim.enable = false;
-
- environment = with config.programs.vim; {
- systemPackages = [ package ];
- variables = rec {
- EDITOR = mkOverride 15 (getExe' package "vim");
- VISUAL = EDITOR;
- };
- };
- };
-}