summaryrefslogtreecommitdiff
path: root/modules/common/vscode.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-02 20:30:02 +0300
commit482bcef47a3b7ee63553c58d200065857ec42b1c (patch)
treeface7032b62c8957df4a84b2fc0c4adc47020f9e /modules/common/vscode.nix
parent029acb0781f5a0e75dfd7a64cf8512c8cf12f07b (diff)
2024-03-02
Diffstat (limited to 'modules/common/vscode.nix')
-rw-r--r--modules/common/vscode.nix47
1 files changed, 13 insertions, 34 deletions
diff --git a/modules/common/vscode.nix b/modules/common/vscode.nix
index 10d4bf6..0780b0b 100644
--- a/modules/common/vscode.nix
+++ b/modules/common/vscode.nix
@@ -69,30 +69,19 @@ in {
]
++ optional cfg.vim.enable vscodevim.vim;
- userSettings = let
- font = config.fontScheme.monospaceFont;
- fontFamily = font.family;
- fontSize = font.size;
- in {
- editor =
- {
- inherit fontFamily fontSize;
- inlayHints = {inherit fontFamily fontSize;};
- codeLens = false;
- cursorStyle = "block";
- detectIndentation = true;
- minimap.enabled = false;
- renderWhitespace = "trailing";
- rulers = [80 120];
- smoothScrolling = false;
- tabCompletion = "on";
- }
- // (let
- surround = 10;
- in {
- cursorSurroundingLines = surround;
- scrollBeyondLastColumn = surround;
- });
+ userSettings = {
+ editor = {
+ codeLens = false;
+ cursorStyle = "block";
+ detectIndentation = true;
+ minimap.enabled = false;
+ renderWhitespace = "trailing";
+ rulers = [80 120];
+ smoothScrolling = false;
+ tabCompletion = "on";
+ cursorSurroundingLines = 10;
+ scrollBeyondLastColumn = 10;
+ };
keyboard.dispatch = "keyCode";
@@ -117,13 +106,6 @@ in {
};
};
- debug.console = {inherit fontFamily fontSize;};
-
- scm = {
- inputFontFamily = fontFamily;
- inputFontSize = fontSize;
- };
-
extensions = {
autoCheckUpdates = false;
autoUpdate = false;
@@ -131,7 +113,6 @@ in {
};
terminal.integrated = {
- inherit fontFamily fontSize;
enableBell = true;
};
@@ -225,8 +206,6 @@ in {
vim = mkIf cfg.vim.enable {
easymotion = true;
- easymotionMarkerFontFamily = fontFamily;
- easymotionMarkerFontSize = fontSize;
leader = " ";