summaryrefslogtreecommitdiff
path: root/modules/common/wget.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/common/wget.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/common/wget.nix')
-rw-r--r--modules/common/wget.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/modules/common/wget.nix b/modules/common/wget.nix
index 1cd8eae..0e8ee64 100644
--- a/modules/common/wget.nix
+++ b/modules/common/wget.nix
@@ -4,9 +4,11 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.wget;
-in {
+in
+{
options.nixfiles.modules.wget.enable = mkEnableOption "wget";
config = mkIf cfg.enable {
@@ -30,6 +32,6 @@ in {
'';
};
- environment.systemPackages = with pkgs; [wget];
+ environment.systemPackages = with pkgs; [ wget ];
};
}