summaryrefslogtreecommitdiff
path: root/modules/darwin/profiles/headful.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/darwin/profiles/headful.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/darwin/profiles/headful.nix')
-rw-r--r--modules/darwin/profiles/headful.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/modules/darwin/profiles/headful.nix b/modules/darwin/profiles/headful.nix
index 826e45a..023386b 100644
--- a/modules/darwin/profiles/headful.nix
+++ b/modules/darwin/profiles/headful.nix
@@ -4,9 +4,11 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.profiles.headful;
-in {
+in
+{
config = mkIf cfg.enable {
nixfiles.modules.homebrew.enable = true;
@@ -23,9 +25,9 @@ in {
];
homebrew.casks = [
- {name = "firefox";}
- {name = "iterm2";}
- {name = "telegram-desktop";}
+ { name = "firefox"; }
+ { name = "iterm2"; }
+ { name = "telegram-desktop"; }
];
};
}