about summary refs log tree commit diff
path: root/modules/endlessh.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/endlessh.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to 'modules/endlessh.nix')
-rw-r--r--modules/endlessh.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/endlessh.nix b/modules/endlessh.nix
index e607935..6a071b8 100644
--- a/modules/endlessh.nix
+++ b/modules/endlessh.nix
@@ -1,16 +1,15 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.endlessh;
 in
 {
-  options.nixfiles.modules.endlessh.enable = mkEnableOption "endlessh";
+  options.nixfiles.modules.endlessh.enable = lib.mkEnableOption "endlessh";
 
   config =
     let
       port = 22;
     in
-    mkIf cfg.enable {
+    lib.mkIf cfg.enable {
       services.endlessh = {
         enable = true;
         inherit port;

Consider giving Nix/NixOS a try! <3