summaryrefslogtreecommitdiff
path: root/modules/eza.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/eza.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/eza.nix')
-rw-r--r--modules/eza.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/eza.nix b/modules/eza.nix
new file mode 100644
index 0000000..96b7d4c
--- /dev/null
+++ b/modules/eza.nix
@@ -0,0 +1,23 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.eza;
+in
+{
+ options.nixfiles.modules.eza.enable = mkEnableOption "eza, an alternative to ls";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.common.shell.aliases = rec {
+ ls = "eza --smart-group --dereference";
+ ll = "${ls} --long --grid";
+ la = "${ll} --header --all";
+ };
+
+ hm.home.packages = [ pkgs.eza ];
+ };
+}