about summary refs log tree commit diff
path: root/modules/firefox/addons.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-03-12 20:17:13 +0300
committerazahi <azat@bahawi.net>2025-03-12 20:17:13 +0300
commitc81dc5a13b469c511fac6fa2390b70422d1b4da5 (patch)
tree4dab5909006ab5c25da6bd9fde6a714c7719ded7 /modules/firefox/addons.nix
parent2025-02-17 (diff)
2025-03-12 HEAD master
Diffstat (limited to 'modules/firefox/addons.nix')
-rw-r--r--modules/firefox/addons.nix99
1 files changed, 50 insertions, 49 deletions
diff --git a/modules/firefox/addons.nix b/modules/firefox/addons.nix
index 3bb23d2..9854f8c 100644
--- a/modules/firefox/addons.nix
+++ b/modules/firefox/addons.nix
@@ -5,10 +5,10 @@
 {
   "bitwarden" = buildFirefoxXpiAddon {
     pname = "bitwarden";
-    version = "2024.11.2";
+    version = "2025.2.0";
     addonId = "{446900e4-71c2-419f-a6a7-df9c091e268b}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4392295/bitwarden_password_manager-2024.11.2.xpi";
-    sha256 = "38faecbfca76086a54e62b6e2036eae45e9d9f9f3aee4c7a72b652593f51b8e7";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4440363/bitwarden_password_manager-2025.2.0.xpi";
+    sha256 = "c4d7f355a2269620482f50edac7fce3c19f515190f24cdf80edc865f71d3a374";
     meta = with lib; {
       homepage = "https://bitwarden.com";
       description = "At home, at work, or on the go, Bitwarden easily secures all your passwords, passkeys, and sensitive information.";
@@ -16,19 +16,18 @@
       mozPermissions = [
         "<all_urls>"
         "*://*/*"
-        "tabs"
-        "contextMenus"
-        "storage"
-        "unlimitedStorage"
+        "alarms"
         "clipboardRead"
         "clipboardWrite"
+        "contextMenus"
         "idle"
-        "alarms"
+        "storage"
+        "tabs"
+        "unlimitedStorage"
+        "webNavigation"
         "webRequest"
         "webRequestBlocking"
-        "webNavigation"
         "file:///*"
-        "https://lastpass.com/export.php"
       ];
       platforms = platforms.all;
     };
@@ -76,10 +75,10 @@
   };
   "indie-wiki-buddy" = buildFirefoxXpiAddon {
     pname = "indie-wiki-buddy";
-    version = "3.11.1";
+    version = "3.13.1";
     addonId = "{cb31ec5d-c49a-4e5a-b240-16c767444f62}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4379107/indie_wiki_buddy-3.11.1.xpi";
-    sha256 = "2b63271fa42e3d46a683605f719de816195471ccd8654771606d6eb811f7596d";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4435453/indie_wiki_buddy-3.13.1.xpi";
+    sha256 = "71dbed6b090604ea299c9661312c1ad5bc208c3ea3012b7890e38fb08994d703";
     meta = with lib; {
       homepage = "https://getindie.wiki/";
       description = "Helping you discover quality, independent wikis!\n\nWhen visiting a Fandom wiki, Indie Wiki Buddy redirects or alerts you of independent alternatives. It also filters search engine results. BreezeWiki is also supported, to reduce clutter on Fandom.";
@@ -334,10 +333,10 @@
   };
   "ipfs-companion" = buildFirefoxXpiAddon {
     pname = "ipfs-companion";
-    version = "3.1.0";
+    version = "3.2.0";
     addonId = "ipfs-firefox-addon@lidel.org";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4172699/ipfs_companion-3.1.0.xpi";
-    sha256 = "784f6d1e0497d86f1e42cfe7de8548b5cc28fabe80e50771d90f59ddf1b9d3c1";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4447471/ipfs_companion-3.2.0.xpi";
+    sha256 = "95b032a90f7e4349cb3778cdb9564b5c89d16c58d9aa12e2f223584ac143fb93";
     meta = with lib; {
       homepage = "https://github.com/ipfs/ipfs-companion";
       description = "Harness the power of IPFS in your browser";
@@ -360,10 +359,10 @@
   };
   "languagetool" = buildFirefoxXpiAddon {
     pname = "languagetool";
-    version = "8.13.2";
+    version = "8.14.3";
     addonId = "languagetool-webextension@languagetool.org";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4396724/languagetool-8.13.2.xpi";
-    sha256 = "e8a93ca046df390aaafeb7ba86254505ed3c593371c1f9e5af6892018d12de66";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4411930/languagetool-8.14.3.xpi";
+    sha256 = "f8c6c6b5ae7591ff62bfcaf93f7831651643312a64e0029fc4c153f7ca75295f";
     meta = with lib; {
       homepage = "https://languagetool.org";
       description = "With this extension you can check text with the free style and grammar checker LanguageTool. It finds many errors that a simple spell checker cannot detect, like mixing up there/their, a/an, or repeating a word.";
@@ -425,6 +424,29 @@
       platforms = platforms.all;
     };
   };
+  "okta" = buildFirefoxXpiAddon {
+    pname = "okta";
+    version = "6.38.0";
+    addonId = "plugin@okta.com";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4441853/okta_browser_plugin-6.38.0.xpi";
+    sha256 = "a26b30c29db3ff139cf313b1e19dbff5ea2836f29d59c2c28411c54e5d02c1fa";
+    meta = with lib; {
+      homepage = "https://www.okta.com";
+      description = "Okta Browser Plugin";
+      mozPermissions = [
+        "tabs"
+        "cookies"
+        "https://*/"
+        "http://*/"
+        "storage"
+        "unlimitedStorage"
+        "webRequest"
+        "webRequestBlocking"
+        "webNavigation"
+      ];
+      platforms = platforms.all;
+    };
+  };
   "plasma-integration" = buildFirefoxXpiAddon {
     pname = "plasma-integration";
     version = "1.9.1";
@@ -473,10 +495,10 @@
   };
   "rikaichamp" = buildFirefoxXpiAddon {
     pname = "rikaichamp";
-    version = "1.22.0";
+    version = "1.23.0";
     addonId = "{59812185-ea92-4cca-8ab7-cfcacee81281}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4371439/10ten_ja_reader-1.22.0.xpi";
-    sha256 = "d6f3197b7e3383f2723b9376d93e03fe515e5c610f9c0723d9618b10d3cc4bf1";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4424537/10ten_ja_reader-1.23.0.xpi";
+    sha256 = "4e37d31ec2c8c7f17de314b0812002de2d394c251dccb04d5eda44751db98660";
     meta = with lib; {
       homepage = "https://github.com/birchill/10ten-ja-reader/";
       description = "Quickly translate Japanese by hovering over words. Formerly released as Rikaichamp.";
@@ -495,27 +517,6 @@
       platforms = platforms.all;
     };
   };
-  "skip-redirect" = buildFirefoxXpiAddon {
-    pname = "skip-redirect";
-    version = "2.3.6";
-    addonId = "skipredirect@sblask";
-    url = "https://addons.mozilla.org/firefox/downloads/file/3920533/skip_redirect-2.3.6.xpi";
-    sha256 = "dbe8950245c1f475c5c1c6daab89c79b83ba4680621c91e80f15be7b09b618ae";
-    meta = with lib; {
-      description = "Some web pages use intermediary pages before redirecting to a final page. This add-on tries to extract the final url from the intermediary url and goes there straight away if successful.";
-      license = licenses.mit;
-      mozPermissions = [
-        "<all_urls>"
-        "clipboardWrite"
-        "contextMenus"
-        "notifications"
-        "storage"
-        "webRequest"
-        "webRequestBlocking"
-      ];
-      platforms = platforms.all;
-    };
-  };
   "switchyomega" = buildFirefoxXpiAddon {
     pname = "switchyomega";
     version = "2.5.10";
@@ -544,10 +545,10 @@
   };
   "ublock-origin" = buildFirefoxXpiAddon {
     pname = "ublock-origin";
-    version = "1.61.2";
+    version = "1.62.0";
     addonId = "uBlock0@raymondhill.net";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4391011/ublock_origin-1.61.2.xpi";
-    sha256 = "ee3a724a46ff32c17d1723077fecc6ede7fdab742154020b51fb6253ddcbba14";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4412673/ublock_origin-1.62.0.xpi";
+    sha256 = "8a9e02aa838c302fb14e2b5bc88a6036d36358aadd6f95168a145af2018ef1a3";
     meta = with lib; {
       homepage = "https://github.com/gorhill/uBlock#ublock-origin";
       description = "Finally, an efficient wide-spectrum content blocker. Easy on CPU and memory.";
@@ -604,10 +605,10 @@
   };
   "violentmonkey" = buildFirefoxXpiAddon {
     pname = "violentmonkey";
-    version = "2.29.0";
+    version = "2.30.0";
     addonId = "{aecec67f-0d10-4fa7-b7c7-609a2db280cf}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4398029/violentmonkey-2.29.0.xpi";
-    sha256 = "2edf39a824476b8a77a57c7c3abdaf3f685a679486e47450fab837b4bd71d469";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4426490/violentmonkey-2.30.0.xpi";
+    sha256 = "82932f9d6ba68a230ef57b1cdcf9f76226b2659f94249eeec0e4ffcc2b644394";
     meta = with lib; {
       homepage = "https://violentmonkey.github.io/";
       description = "Userscript support for browsers, open source.";

Consider giving Nix/NixOS a try! <3