about summary refs log tree commit diff
path: root/modules/foot.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/foot.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to 'modules/foot.nix')
-rw-r--r--modules/foot.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/foot.nix b/modules/foot.nix
index 502e143..c449864 100644
--- a/modules/foot.nix
+++ b/modules/foot.nix
@@ -4,16 +4,15 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.foot;
 in
 {
-  options.nixfiles.modules.foot.enable = mkEnableOption "Foot terminal emulator";
+  options.nixfiles.modules.foot.enable = lib.mkEnableOption "Foot terminal emulator";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm = {
-      home.packages = with pkgs; [ libsixel ];
+      home.packages = [ pkgs.libsixel ];
 
       programs.foot = {
         enable = true;
@@ -26,7 +25,7 @@ in
               in
               "${n}x${n}";
           };
-          scrollback.lines = pow 2 14;
+          scrollback.lines = lib.pow 2 14;
         };
       };
     };

Consider giving Nix/NixOS a try! <3