summaryrefslogtreecommitdiff
path: root/modules/foot.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/foot.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/foot.nix')
-rw-r--r--modules/foot.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/foot.nix b/modules/foot.nix
new file mode 100644
index 0000000..502e143
--- /dev/null
+++ b/modules/foot.nix
@@ -0,0 +1,34 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.foot;
+in
+{
+ options.nixfiles.modules.foot.enable = mkEnableOption "Foot terminal emulator";
+
+ config = mkIf cfg.enable {
+ hm = {
+ home.packages = with pkgs; [ libsixel ];
+
+ programs.foot = {
+ enable = true;
+ settings = {
+ main = {
+ utmp-helper = "${pkgs.libutempter}/lib/utempter/utempter";
+ pad =
+ let
+ n = toString config.stylix.fonts.sizes.terminal;
+ in
+ "${n}x${n}";
+ };
+ scrollback.lines = pow 2 14;
+ };
+ };
+ };
+ };
+}