about summary refs log tree commit diff
path: root/modules/games/lutris.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/games/lutris.nix
parent2024-04-18 (diff)
2024-04-21
Diffstat (limited to 'modules/games/lutris.nix')
-rw-r--r--modules/games/lutris.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/games/lutris.nix b/modules/games/lutris.nix
new file mode 100644
index 0000000..62fe521
--- /dev/null
+++ b/modules/games/lutris.nix
@@ -0,0 +1,31 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+with lib;
+let
+  cfg = config.nixfiles.modules.games.lutris;
+in
+{
+  options.nixfiles.modules.games.lutris.enable = mkEnableOption "Lutris";
+
+  config = mkIf cfg.enable {
+    nixfiles.modules.games = {
+      gamemode.enable = true;
+      mangohud.enable = true;
+      steam-run.enable = true;
+    };
+
+    hm.home.packages = with pkgs; [
+      (lutris.override {
+        extraPkgs = _: [
+          vkBasalt
+          wine
+          winetricks
+        ];
+      })
+    ];
+  };
+}

Consider giving Nix/NixOS a try! <3