summaryrefslogtreecommitdiff
path: root/modules/games/steam-run.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/games/steam-run.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/games/steam-run.nix')
-rw-r--r--modules/games/steam-run.nix89
1 files changed, 89 insertions, 0 deletions
diff --git a/modules/games/steam-run.nix b/modules/games/steam-run.nix
new file mode 100644
index 0000000..cfee8ae
--- /dev/null
+++ b/modules/games/steam-run.nix
@@ -0,0 +1,89 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.games.steam-run;
+in
+{
+ options.nixfiles.modules.games.steam-run = {
+ enable = mkEnableOption "native Steam runtime";
+
+ quirks = {
+ blackIsleStudios = mkEnableOption "fixes for games from Black Isle Studios";
+ cryptOfTheNecrodancer = mkEnableOption ''fixes for "Crypt of the NecroDancer" issues'';
+ mountAndBladeWarband = mkEnableOption ''fixes for "Mount & Blade: Warband" issues'';
+ };
+ };
+
+ config = mkIf cfg.enable {
+ nixfiles.modules = {
+ common.nix.allowedUnfreePackages = [
+ "steam"
+ "steam-run"
+ ];
+
+ games = {
+ enable32BitSupport = true;
+ gamemode.enable = true;
+ mangohud.enable = true;
+ };
+ };
+
+ hm.home.packages = with pkgs; [
+ (steam.override {
+ extraLibraries =
+ _:
+ with cfg.quirks;
+ optional blackIsleStudios openssl_1_0_0
+ ++ optionals cryptOfTheNecrodancer [
+ (import (builtins.fetchTarball {
+ url = "https://github.com/NixOS/nixpkgs/archive/d1c3fea7ecbed758168787fe4e4a3157e52bc808.tar.gz";
+ sha256 = "0ykm15a690v8lcqf2j899za3j6hak1rm3xixdxsx33nz7n3swsyy";
+ }) { inherit (config.nixpkgs) config localSystem; }).flac
+ ]
+ ++ optionals mountAndBladeWarband [
+ (glew.overrideAttrs (
+ _: super:
+ let
+ opname = super.pname;
+ in
+ rec {
+ pname = "${opname}-steam-run-fix";
+ inherit (super) version;
+ src = fetchurl {
+ url = "mirror://sourceforge/${opname}/${opname}-${version}.tgz";
+ hash = "sha256-BN6R5+Z2MDm8EZQAlc2cf4gLq6ghlqd2X3J6wFqZPJU=";
+ };
+ }
+ ))
+ (fmodex.overrideAttrs (
+ _: super:
+ let
+ opname = super.pname;
+ in
+ rec {
+ pname = "${opname}-steam-run-fix";
+ inherit (super) version;
+ installPhase =
+ let
+ libPath = makeLibraryPath [
+ alsa-lib
+ libpulseaudio
+ stdenv.cc.cc
+ ];
+ in
+ ''
+ install -Dm755 api/lib/libfmodex64-${version}.so $out/lib/libfmodex64.so
+ patchelf --set-rpath ${libPath} $out/lib/libfmodex64.so
+ '';
+ }
+ ))
+ ];
+ }).run
+ ];
+ };
+}