about summary refs log tree commit diff
path: root/modules/games/steam.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
committerazahi <azat@bahawi.net>2025-02-17 02:21:56 +0300
commit59180328cda59817d71cd58c8f48ead047375064 (patch)
tree2cdd7d1bfa309839ef624c19daf283f510aacf69 /modules/games/steam.nix
parent2025-02-05 (diff)
2025-02-17
Diffstat (limited to 'modules/games/steam.nix')
-rw-r--r--modules/games/steam.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/modules/games/steam.nix b/modules/games/steam.nix
index d8c6964..9d41b8f 100644
--- a/modules/games/steam.nix
+++ b/modules/games/steam.nix
@@ -4,14 +4,13 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.games.steam;
 in
 {
-  options.nixfiles.modules.games.steam.enable = mkEnableOption "Steam runtime";
+  options.nixfiles.modules.games.steam.enable = lib.mkEnableOption "Steam runtime";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     nixfiles.modules = {
       common = {
         nix.allowedUnfreePackages = [

Consider giving Nix/NixOS a try! <3