summaryrefslogtreecommitdiff
path: root/modules/games/steam.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/games/steam.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/games/steam.nix')
-rw-r--r--modules/games/steam.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/games/steam.nix b/modules/games/steam.nix
new file mode 100644
index 0000000..5883b0e
--- /dev/null
+++ b/modules/games/steam.nix
@@ -0,0 +1,33 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.games.steam;
+in
+{
+ options.nixfiles.modules.games.steam.enable = mkEnableOption "Steam runtime";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules = {
+ common.nix.allowedUnfreePackages = [
+ "steam"
+ "steam-original"
+ ];
+
+ games = {
+ enable32BitSupport = true;
+ gamemode.enable = true;
+ mangohud.enable = true;
+ };
+ };
+
+ hm.home.packages = with pkgs; [
+ (steam.override { extraEnv.MANGOHUD = 1; })
+ protontricks
+ ];
+ };
+}