summaryrefslogtreecommitdiff
path: root/modules/k3s.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-02 14:30:08 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-02 14:30:08 +0300
commit3c61dc9cc35ed201877d81b1b7ad848f1ac9855e (patch)
treecd9c766d3046cbaddfdd48ef34d6229e37d36591 /modules/k3s.nix
parent9b3ebd974bde5c8ebe1f8c8f049f7ee2c6462655 (diff)
2024-05-02
Diffstat (limited to 'modules/k3s.nix')
-rw-r--r--modules/k3s.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/k3s.nix b/modules/k3s.nix
index 1ad99c3..01c77dd 100644
--- a/modules/k3s.nix
+++ b/modules/k3s.nix
@@ -1,7 +1,9 @@
{
config,
+ inputs,
lib,
pkgs,
+ this,
...
}:
with lib;
@@ -59,5 +61,12 @@ in
kubectx
kubernetes-helm
];
+
+ topology = {
+ nodes.${this.hostname}.services.k3s = {
+ name = "K3s";
+ icon = "${inputs.self}/media/k3s.svg";
+ };
+ };
};
}