summaryrefslogtreecommitdiff
path: root/modules/loki.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-05 14:28:31 +0300
commit389becf9700d3dee7f09073ce4d235fc7c30b5c8 (patch)
tree3db9d75bd5275614fc904184c97b3133f38bc3d0 /modules/loki.nix
parent3cd3233f7eaf2a8a715d587820d6d4577a24d958 (diff)
2024-05-05
Diffstat (limited to 'modules/loki.nix')
-rw-r--r--modules/loki.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/loki.nix b/modules/loki.nix
index c446848..75e534b 100644
--- a/modules/loki.nix
+++ b/modules/loki.nix
@@ -2,6 +2,7 @@
config,
lib,
libNginx,
+ this,
...
}:
with lib;
@@ -120,5 +121,11 @@ in
"d ${storage.filesystem.chunks_directory} 0700 loki loki - -"
"d ${storage.filesystem.rules_directory} 0700 loki loki - -"
];
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.loki = {
+ info = domain;
+ };
+ };
};
}