about summary refs log tree commit diff
path: root/modules/nixfiles/games/gamemode.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-08-12 22:53:53 +0300
committerAzat Bahawi <azat@bahawi.net>2022-08-12 22:53:53 +0300
commit61b94f0dd06cac0f7dcd38cce80f2a7ab8376098 (patch)
treeb703a9fe11eae6c4cae4e4682f02caf0caa171d0 /modules/nixfiles/games/gamemode.nix
2022-08-12
Diffstat (limited to 'modules/nixfiles/games/gamemode.nix')
-rw-r--r--modules/nixfiles/games/gamemode.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/nixfiles/games/gamemode.nix b/modules/nixfiles/games/gamemode.nix
new file mode 100644
index 0000000..a74b651
--- /dev/null
+++ b/modules/nixfiles/games/gamemode.nix
@@ -0,0 +1,13 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.games.gamemode;
+in {
+  options.nixfiles.modules.games.gamemode.enable =
+    mkEnableOption "Whether to enable GameMode.";
+
+  config = mkIf cfg.enable {programs.gamemode.enable = true;};
+}

Consider giving Nix/NixOS a try! <3