summaryrefslogtreecommitdiff
path: root/modules/nixfiles/wireguard.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-08-20 00:23:51 +0300
committerAzat Bahawi <azat@bahawi.net>2022-08-20 00:23:51 +0300
commite7941cee341350e2b59b33abef99dfc1c36c2ea9 (patch)
treec6fb9caae84c39b714e0267d83b0d98d849ad481 /modules/nixfiles/wireguard.nix
parent508aee982ae2fda532742dffdc781f78351e115f (diff)
2022-08-20
Diffstat (limited to 'modules/nixfiles/wireguard.nix')
-rw-r--r--modules/nixfiles/wireguard.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/modules/nixfiles/wireguard.nix b/modules/nixfiles/wireguard.nix
index e35d0ee..fa7ad34 100644
--- a/modules/nixfiles/wireguard.nix
+++ b/modules/nixfiles/wireguard.nix
@@ -17,7 +17,7 @@ in {
};
client = {
- enable = mkEnableOption "Whether to enable WireGuard client.";
+ enable = mkEnableOption "WireGuard client";
enableTrafficRouting = mkOption {
description = "Whether to enable traffic routing through the sever.";
@@ -27,10 +27,7 @@ in {
};
server = {
- enable = mkEnableOption ''
- Whether to enable WireGuard server. This module requires
- <option>networking.nat.externalInterface</option> to be set.
- '';
+ enable = mkEnableOption "WireGuard server";
ipv4.address = mkOption {
description = "IPv4 address to bind to.";