about summary refs log tree commit diff
path: root/modules/nixos/acme.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/acme.nix
parent2022-11-20 (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/acme.nix')
-rw-r--r--modules/nixos/acme.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/nixos/acme.nix b/modules/nixos/acme.nix
new file mode 100644
index 0000000..d3ad661
--- /dev/null
+++ b/modules/nixos/acme.nix
@@ -0,0 +1,32 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.acme;
+in {
+  imports = [
+    (mkAliasOptionModule ["certs"] ["security" "acme" "certs"])
+  ];
+
+  options.nixfiles.modules.acme = {
+    enable = mkEnableOption "ACME";
+
+    email = mkOption {
+      description = "Email for notifications.";
+      type = with types; str;
+      default = "admin+acme@${my.domain.shire}";
+    };
+  };
+
+  config = mkIf cfg.enable {
+    security.acme = {
+      acceptTerms = true;
+      defaults = {
+        inherit (cfg) email;
+        validMinDays = 60;
+      };
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3