summaryrefslogtreecommitdiff
path: root/modules/nixos/bluetooth.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/nixos/bluetooth.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/nixos/bluetooth.nix')
-rw-r--r--modules/nixos/bluetooth.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/modules/nixos/bluetooth.nix b/modules/nixos/bluetooth.nix
index 26d081d..117aff7 100644
--- a/modules/nixos/bluetooth.nix
+++ b/modules/nixos/bluetooth.nix
@@ -1,16 +1,13 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.bluetooth;
-in {
- options.nixfiles.modules.bluetooth.enable =
- mkEnableOption "Bluetooth support";
+in
+{
+ options.nixfiles.modules.bluetooth.enable = mkEnableOption "Bluetooth support";
config = mkIf cfg.enable {
- ark.directories = ["/var/lib/bluetooth"];
+ ark.directories = [ "/var/lib/bluetooth" ];
hardware.bluetooth = {
enable = true;