summaryrefslogtreecommitdiff
path: root/modules/nixos/bluetooth.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/bluetooth.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/bluetooth.nix')
-rw-r--r--modules/nixos/bluetooth.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/modules/nixos/bluetooth.nix b/modules/nixos/bluetooth.nix
deleted file mode 100644
index 117aff7..0000000
--- a/modules/nixos/bluetooth.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-{ config, lib, ... }:
-with lib;
-let
- cfg = config.nixfiles.modules.bluetooth;
-in
-{
- options.nixfiles.modules.bluetooth.enable = mkEnableOption "Bluetooth support";
-
- config = mkIf cfg.enable {
- ark.directories = [ "/var/lib/bluetooth" ];
-
- hardware.bluetooth = {
- enable = true;
- settings.General.FastConnectable = true;
- input.General = {
- IdleTimeout = 15;
- UserspaceHID = true;
- };
- };
- };
-}