summaryrefslogtreecommitdiff
path: root/modules/nixos/common/ark.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/common/ark.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/common/ark.nix')
-rw-r--r--modules/nixos/common/ark.nix64
1 files changed, 0 insertions, 64 deletions
diff --git a/modules/nixos/common/ark.nix b/modules/nixos/common/ark.nix
deleted file mode 100644
index 6c7148f..0000000
--- a/modules/nixos/common/ark.nix
+++ /dev/null
@@ -1,64 +0,0 @@
-{
- config,
- inputs,
- lib,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.ark;
-in
-{
- imports = [
- (mkAliasOptionModule [ "ark" ] [
- "nixfiles"
- "modules"
- "ark"
- ])
- inputs.impermanence.nixosModules.impermanence
- ];
-
- options.nixfiles.modules.ark =
- let
- mkListOfAnythingOption = mkOption {
- type = with types; listOf anything; # Assumed to be matching with the upstream type.
- default = [ ];
- };
- in
- {
- enable = mkEnableOption "persistent storage support via impermanence";
-
- path = mkOption {
- type = types.str;
- default = "/ark";
- };
-
- directories = mkListOfAnythingOption;
- files = mkListOfAnythingOption;
- # hm = {
- # directories = mkListOfAnythingOption;
- # files = mkListOfAnythingOption;
- # };
- };
-
- config = mkIf cfg.enable {
- environment.persistence.${cfg.path} = {
- hideMounts = true;
- enableDebugging = false;
- inherit (cfg) directories files;
- };
-
- # NOTE We can't reliably[1] use this, so for the time being, this will stay
- # commented out. Probably forever.
- #
- # [1]: https://github.com/nix-community/impermanence/issues/18
- #
- # hm = {
- # imports = [inputs.impermanence.nixosModules.home-manager.impermanence];
- # home.persistence."${cfg.path}/${config.my.home}" = {
- # allowOther = false;
- # inherit (cfg.hm) directories files;
- # };
- # };
- };
-}