summaryrefslogtreecommitdiff
path: root/modules/nixos/common/users.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/common/users.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/common/users.nix')
-rw-r--r--modules/nixos/common/users.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/nixos/common/users.nix b/modules/nixos/common/users.nix
deleted file mode 100644
index a92a38e..0000000
--- a/modules/nixos/common/users.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{
- lib,
- localUsername ? lib.my.username,
- ...
-}:
-with lib;
-let
- home = "/home/${localUsername}";
-in
-{
- ark.directories = [ home ];
-
- users = {
- mutableUsers = false;
-
- users = {
- root.hashedPassword = "@HASHED_PASSWORD@";
-
- ${localUsername} = {
- isNormalUser = true;
- uid = 1000;
- description = my.fullname;
- inherit home;
- inherit (my) hashedPassword;
- openssh.authorizedKeys.keys = [ my.ssh.key ];
- extraGroups = [ "wheel" ];
- };
- };
- };
-}