summaryrefslogtreecommitdiff
path: root/modules/nixos/games/mangohud.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/games/mangohud.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/games/mangohud.nix')
-rw-r--r--modules/nixos/games/mangohud.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/modules/nixos/games/mangohud.nix b/modules/nixos/games/mangohud.nix
new file mode 100644
index 0000000..d693c82
--- /dev/null
+++ b/modules/nixos/games/mangohud.nix
@@ -0,0 +1,26 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.games.mangohud;
+in {
+ options.nixfiles.modules.games.mangohud.enable = mkEnableOption "MangoHud";
+
+ config = mkIf cfg.enable {
+ hm.programs.mangohud = {
+ enable = true;
+ settings = {
+ fps = true;
+ frame_timing = true;
+ gpu_stats = true;
+ gpu_temp = true;
+ cpu_stats = true;
+ cpu_temp = true;
+ ram = true;
+ vram = true;
+ };
+ };
+ };
+}