summaryrefslogtreecommitdiff
path: root/modules/nixos/games/steam.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
committerAzat Bahawi <azat@bahawi.net>2024-03-31 21:29:27 +0300
commit9a5427e3a0c0ccf2a82dc503149a26b23fbd6004 (patch)
treef28beec29deeea36038615a8fb98a810891940b5 /modules/nixos/games/steam.nix
parent4ad0c3afc1f6caf0c3f05f99a15b22178f2c190b (diff)
2024-03-31
Diffstat (limited to 'modules/nixos/games/steam.nix')
-rw-r--r--modules/nixos/games/steam.nix16
1 files changed, 10 insertions, 6 deletions
diff --git a/modules/nixos/games/steam.nix b/modules/nixos/games/steam.nix
index 7262d7f..5883b0e 100644
--- a/modules/nixos/games/steam.nix
+++ b/modules/nixos/games/steam.nix
@@ -4,15 +4,19 @@
pkgs,
...
}:
-with lib; let
+with lib;
+let
cfg = config.nixfiles.modules.games.steam;
-in {
- options.nixfiles.modules.games.steam.enable =
- mkEnableOption "Steam runtime";
+in
+{
+ options.nixfiles.modules.games.steam.enable = mkEnableOption "Steam runtime";
config = mkIf cfg.enable {
nixfiles.modules = {
- common.nix.allowedUnfreePackages = ["steam" "steam-original"];
+ common.nix.allowedUnfreePackages = [
+ "steam"
+ "steam-original"
+ ];
games = {
enable32BitSupport = true;
@@ -22,7 +26,7 @@ in {
};
hm.home.packages = with pkgs; [
- (steam.override {extraEnv.MANGOHUD = 1;})
+ (steam.override { extraEnv.MANGOHUD = 1; })
protontricks
];
};