summaryrefslogtreecommitdiff
path: root/modules/nixos/gnupg.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/gnupg.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/gnupg.nix')
-rw-r--r--modules/nixos/gnupg.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/nixos/gnupg.nix b/modules/nixos/gnupg.nix
new file mode 100644
index 0000000..b86be9b
--- /dev/null
+++ b/modules/nixos/gnupg.nix
@@ -0,0 +1,38 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.gnupg;
+in {
+ options.nixfiles.modules.gnupg.pinentry = mkOption {
+ description = "Name of a pinentry implementation.";
+ type = types.str;
+ default = "curses";
+ };
+
+ config = mkIf cfg.enable {
+ hm = {
+ programs.gpg.homedir = "${config.dirs.data}/gnupg";
+
+ services.gpg-agent = {
+ enable = true;
+
+ enableSshSupport = true;
+ enableScDaemon = false;
+
+ defaultCacheTtl = 999999;
+ defaultCacheTtlSsh = 999999;
+ maxCacheTtl = 999999;
+ maxCacheTtlSsh = 999999;
+
+ grabKeyboardAndMouse = true;
+
+ sshKeys = [my.pgp.grip];
+
+ pinentryFlavor = cfg.pinentry;
+ };
+ };
+ };
+}