summaryrefslogtreecommitdiff
path: root/modules/nixos/gnupg.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/nixos/gnupg.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/nixos/gnupg.nix')
-rw-r--r--modules/nixos/gnupg.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/modules/nixos/gnupg.nix b/modules/nixos/gnupg.nix
deleted file mode 100644
index ad2c939..0000000
--- a/modules/nixos/gnupg.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.gnupg;
-in
-{
- options.nixfiles.modules.gnupg.pinentry = mkOption {
- description = "Name of a pinentry implementation.";
- type = types.package;
- default = pkgs.pinentry-curses;
- };
-
- config = mkIf cfg.enable {
- hm = {
- programs.gpg.homedir = "${config.dirs.data}/gnupg";
-
- services.gpg-agent = {
- enable = true;
-
- enableSshSupport = true;
- enableScDaemon = false;
-
- defaultCacheTtl = 999999;
- defaultCacheTtlSsh = 999999;
- maxCacheTtl = 999999;
- maxCacheTtlSsh = 999999;
-
- grabKeyboardAndMouse = true;
-
- sshKeys = [ my.pgp.grip ];
-
- pinentryPackage = cfg.pinentry;
- };
- };
- };
-}