about summary refs log tree commit diff
path: root/modules/nixos/hydra.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /modules/nixos/hydra.nix
parent2022-11-20 (diff)
2022-12-17
Diffstat (limited to 'modules/nixos/hydra.nix')
-rw-r--r--modules/nixos/hydra.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/nixos/hydra.nix b/modules/nixos/hydra.nix
new file mode 100644
index 0000000..590fecb
--- /dev/null
+++ b/modules/nixos/hydra.nix
@@ -0,0 +1,57 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.hydra;
+in {
+  options.nixfiles.modules.hydra = {
+    enable = mkEnableOption "Hydra";
+
+    domain = mkOption {
+      description = "Domain name sans protocol scheme.";
+      type = with types; str;
+      default = "hydra.${config.networking.domain}";
+    };
+
+    port = mkOption {
+      description = "Port.";
+      type = with types; port;
+      default = 7754;
+    };
+  };
+
+  config = mkIf cfg.enable {
+    nixfiles.modules = {
+      nginx = {
+        enable = true;
+        upstreams.hydra.servers."127.0.0.1:${toString cfg.port}" = {};
+        virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://hydra";
+      };
+      postgresql.enable = true;
+    };
+
+    services = let
+      db = "hydra";
+    in {
+      hydra = {
+        enable = true;
+        listenHost = "127.0.0.1";
+        inherit (cfg) port;
+        dbi = "dbi:Pg:dbname=${db};user=${db}";
+        hydraURL = cfg.domain;
+      };
+
+      postgresql = {
+        ensureDatabases = [db];
+        ensureUsers = [
+          {
+            name = db;
+            ensurePermissions."DATABASE \"${db}\"" = "ALL";
+          }
+        ];
+      };
+    };
+  };
+}

Consider giving Nix/NixOS a try! <3